Custom link not working on PRO slider LIST theme

Resolved 6 posts from 2 participants
  • Started 5 years, 8 months ago ago by James W.
  • Replied 5 years, 8 months ago ago by Constantin
Viewing 7 posts - 1 through 7 (of 7 total)
  • #1973

    James W.

    I am using the LIST theme to show images. Each item has been configured with a unique clickable URL, which is set to link to a page in my site.

    The slider can be found here:
    http://www.jessicaadams.com/horoscopes/

    E.g. the list item “Aries Lady Gaga” should link here:
    http://www.jessicaadams.com/astrology/sun-signs/aries/

    Instead, it links to the image using this URL:
    http://www.jessicaadams.com/astrology/sun-signs/aries/aries-lady-gaga-artpop-album-cover/

    Other items are not behaving consistently as I would expect with a defined URL also.

    I am wondering if this is a function of 3.0.3. It seems that the URL isn’t translating correctly, and the behaviour I’m seeing is WordPress finding the next best item in the database.

    Can you please confirm the behaviour?

    Thanks,
    James

    #1975

    Constantin

    Can you please tell me what kind of content are you using into the slider (posts, mixed or images)?

    #1977

    Constantin

    Hi James,

    Are you still having trouble with the custom links? Haven’t received your reply yet, please let me know, thank you.
    Also, as I asked on your other thread, can we continue this by e-mail since I also need to send you some files for testing?

    #1980

    James W.

    Slides are images. The URLS should link to pages. You can send files by email for testing. Cheers. Details are in my registration.

    #1981

    Constantin

    Hi James,

    E-mailed you the files. Regarding the links issue, custom URL works on both posts and images. Please make sure that for each individual slide the checkbox Link slide to post isn’t checked. When checked, even if a link is specified, the URL will be the post/attachment permalink.

    #1984

    James W.

    Hi this was definitely my error. Thanks for the guidance on this. I had the URL entered AND ‘link to post’ active. That’s what was causing the problem. I now see the nuance of what it was coded that way… so you could place anchors in the URL box. Very neat.

    #1985

    Constantin

    Now that you pointed this out, I realize the problem is the UI, it’s not clear. We’ll revise this into the next update.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.