Illegal String Offset

Resolved 5 posts from 2 participants
  • Started 3 years, 3 months ago ago by TimothyPaul
  • Replied 3 years, 2 months ago ago by Constantin
Viewing 6 posts - 1 through 6 (of 6 total)
  • #2691

    TimothyPaul

    Hello – when I go to insert shortcode into a page or post – I see the following problem

    Video ID
    Warning: Illegal string offset ‘video_id’ in /home/drcade/public_html/wp-content/plugins/codeflavors-vimeo-video-post-lite/includes/libs/video-list-table.class.php on line 69

    Duration
    Warning: Illegal string offset ‘duration’ in /home/drcade/public_html/wp-content/plugins/codeflavors-vimeo-video-post-lite/includes/libs/video-list-table.class.php on line 78
    0:00

    But this is in “pages” that should not have a video. When I filter by catagory , I see the catagory listed with a (4) next to it, but when I filter – it is empty.

    Thanks…TP

    #2692

    Constantin

    Hi,

    Can you please tell me where do you see this problem? Is it in front-end or back-end? I don’t really understand how you use the plugin, if you could please give me more details I may be able to figure out what is happening. Thank you.

    #2693

    TimothyPaul

    Hi Constantin, thank you for the quick response.

    I guess in the front end. I was able to add my video catagories with no problem, and then add videos with no problem.

    The Truth About Cancer

    But then when I go to create a post or a page and add the video shortcode, the above error is what I am seeing.

    I can create an admin user for you if you would like to look.

    Thanks…TP

    #2695

    Constantin

    Hi,

    Please do create an admin for me to test. Also, please include temporary FTP access so I can debug the code, thank you. Please send the details using the contact form: https://codeflavors.com/contact/

    #2699

    Constantin

    Hi,

    Thank you for the FTP login. I had a look at the page you mentioned above and I see that the video is displayed correctly, no error. Can you please point me to a page where the video embed isn’t working and the error message you mentioned is shown from PHP?
    Unless I see the actual error, there’s not much that I can debug. Please let me know, thank you.
    Also, please send a temporary WP admin user credentials so I can login to your back-end and see what’s happening, thank you.

    #2702

    Constantin

    Hi,

    Thank you for the credentials, I had a look and managed to find and solve the problem. This bug was caused on your website by a filter set by your WordPress theme on all queries, a filter that checks to see if the currently running query is a search and if it is it removes all post types and leaves only post, page and portfolio post type into the query.

    You should contact the theme author and ask him/them to only add post type portfolio instead of completely replacing the post type parameter from the query and set it to only those 3 post types. The function name that does this in your WordPress theme is ut_filter_search().

    Anyway, I will implement this modification in all plugin versions so you won’t have this problem in the future.

    Again, thank you for all your help, please make sure you remove all temporary logins for WP admin and FTP.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.